Trying to use Google API to change a users OU


Question for the experts. Trying to use Google API to change a users OU. When I select the function I can choose the user, Google> User, however when I go to define the OU there is no list of existing OU's to select from, when I type it in it tells me not found. The only option to choose it seems is event.Google.Google.User.OrgUnit which seems to be whatever their existing OU is. How can I define an OU I want the user moved into?


This topic has been closed for comments

17 replies

Userlevel 2
Badge +2

Hey Brian - just so I understand this correctly. Are you currently trying to build a workflow in BetterCloud?


Open Thread in Slack

Yes


Open Thread in Slack
Userlevel 2
Badge +2

In what step are you trying to select the OU?


Open Thread in Slack

Google option is Move user "Select user" to "Select org unit" Org unit

I can select the user but when I go to select org unit there is only the option to choose google.user.orgunit


Open Thread in Slack
Userlevel 2
Badge +2

Just double checking - what is your When trigger on this?


Open Thread in Slack

When OKta - New user exceeds it's threshold


Open Thread in Slack

Even if I create a new workflow where Any new user is created in google

I still don't have the options to define the OU to build into


Open Thread in Slack
Userlevel 2
Badge +2

Hmm it should be working to just type it in and get auto complete 🤔


Open Thread in Slack

I would agree. Which is why I'm asking about it htere


Open Thread in Slack

When I type it in I get no matches. Tried different OU's as well


Open Thread in Slack

Even typing / gets no matches


Open Thread in Slack

I can add groups fine and search them


Open Thread in Slack
Userlevel 2
Badge +4

Interesting! @brian.rea - I tested your workflow and I am able to get the type ahead - have you chatted our support team?


Open Thread in Slack

I havenot


Open Thread in Slack

I guess I will have to do that. Thanks


Open Thread in Slack
Userlevel 2
Badge +4

Keep me posted!


Open Thread in Slack

I’ve seen this happen before, especially in Chrome. I want to say that I tried a different machine/browser and auto-populate was working. 🤷



Open Thread in Slack